Ubuntu 21.04에 Mecab-ko 설치 중 apt 관련 오류 발생시

Posted on Tue, Feb 8, 2022 NLP Ubuntu

TL;DR

sudo apt-get update && sudo apt-get install -y automake
bash <(curl -s https://raw.githubusercontent.com/konlpy/konlpy/master/scripts/mecab.sh)

문제 상황

문제 원인

해결법

automake를 찾는 스크립트가 에러가 있는 듯 하다.

간단하게 수동으로 apt를 통해 automake를 설치해주면, 해당 커맨드가 있을 경우 automake 설치 함수를 건너뛰기 때문에 아래 명령어 입력후, 기존 스크립트를 다시 실행하면 설치가 잘 진행된다.

sudo apt-get update && sudo apt-get install -y automake